Kyloe DataTools (DupliKit) - Decreased merging speed

Incident Report for Kyloe Partners

Resolved

This incident has been resolved.
Posted May 14, 2025 - 15:42 UTC

Identified

We have identified an issue where some clients are experiencing slower than normal merge speeds.

Our developers have a fix for the issue and we will be releasing this today.
Posted May 14, 2025 - 08:56 UTC
This incident affected: Kyloe DataTools (DupliKit (EMEA/APAC), DupliKit (US)).