Duplikit is currently experiencing performance issues.
Incident Report for Kyloe
Resolved
This incident has been resolved.
Posted Dec 24, 2021 - 15:19 UTC
Investigating
We are currently investigating this issue.
Posted Dec 22, 2021 - 12:09 UTC
This incident affected: DataTools (DupliKit).